Cloud UI - annotations unexpectedly deleted

Incident Report for Pix4D

Resolved

We have restored the annotations that were deleted during the time of the incident. We recommend refreshing the affected datasets.
Posted Feb 13, 2026 - 12:34 UTC

Update

We have fixed the visual glitches of all affected datasets. We are proceeding with restoring the annotations of the affected datasets.
Posted Feb 13, 2026 - 09:45 UTC

Update

We have identified a solution to restore deleted annotations and fix visual glitches. We are currently running tests.
Posted Feb 12, 2026 - 15:38 UTC

Update

We are investigating solutions to restore the deleted annotations. We will communicate with the affected organizations.
Posted Feb 12, 2026 - 09:02 UTC

Monitoring

Annotations were unexpectedly deleted for datasets where new annotations were created during the time of the incident.
A fix has been implemented, so no more annotations will be unexpectedly deleted.
Posted Feb 11, 2026 - 16:11 UTC

Investigating

We are currently investigating the issue.
Posted Feb 11, 2026 - 08:28 UTC
This incident affected: PIX4Dcatch and PIX4Dcloud.