Pix4Dcloud and Pix4Dcatch outage

Incident Report for Pix4D

Resolved

The issue has been identified and resolved.
Posted Oct 13, 2025 - 11:28 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 13, 2025 - 10:54 UTC

Identified

Issue with interacting with the datasets from the Pix4Dcloud UI and Pix4Dcatch.
Posted Oct 13, 2025 - 09:54 UTC
This incident affected: PIX4Dcatch and PIX4Dcloud.