High database load

Incident Report for Pix4D

Resolved

We are closing the incident as resolved.
Posted Nov 10, 2025 - 11:04 UTC

Monitoring

The fix has been applied and the load decreased immediately. This change was a modification we did not rollback entirely on Friday. We are monitoring the situation.
Posted Nov 10, 2025 - 10:31 UTC

Identified

We found the issue and are working on deploying a patch.
Posted Nov 10, 2025 - 09:54 UTC

Investigating

We are currently observing a high load on our database, we are investigating the cause.
Posted Nov 10, 2025 - 08:17 UTC
This incident affected: Pix4D Licensing system, PIX4Dcloud, and PIX4Dengine Cloud API.