The maintenance is finished. We will keep observing the traffic all day and perform adjustment when needed.
Posted Nov 25, 2025 - 11:02 UTC
Completed
The scheduled maintenance has been completed.
Posted Nov 25, 2025 - 11:00 UTC
Verifying
We partially applied the maintenance and are currently observing the traffic.
Posted Nov 25, 2025 - 10:47 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 25, 2025 - 09:00 UTC
Scheduled
In our commitment to improving service reliability and performance, we are moving our API traffic to a new infrastructure. This upgrade aims to provide improved reliability, performance, and scalability for the Cloud API.
During that time, we do not expect any interruption in the Cloud API. The traffic will be moved transparently.
Posted Nov 11, 2025 - 15:51 UTC
This scheduled maintenance affected: Processing Infrastructures (Processing infrastructure US, Processing infrastructure DE, Processing infrastructure JP, Processing infrastructure KR, Processing infrastructure CA) and Pix4D Licensing system, PIX4Dcatch, PIX4Dcloud, PIX4Dengine Cloud API.