Elevated API Errors
Incident Report for Pix4D
Postmortem

To improve our observability of production we activated some tracing in our backend services which causes our API to fail for a small percentage of the calls. The component throwing those errors were not compatible with the tracing mechanism we activated and we failed to see those problems during the test phase.

We rolled back our change and will fix this incompatibility issue before activating the performance tracing again.

Posted Jan 25, 2021 - 14:09 UTC

Resolved
We've experienced an elevated level of API errors and have found the issue. A fix will be shortly deployed.
Posted Jan 18, 2021 - 12:30 UTC