High database load

Incident Report for Pix4D

Resolved

The load is resolved now. The incident is closed now.
Posted Nov 07, 2025 - 16:11 UTC

Update

The mitigation is fully in place. We are continuing to monitor the situation to ensure the database load remains stable.
Posted Nov 07, 2025 - 15:25 UTC

Update

The mitigation is not yet fully deployed. The load is getting better but still not at its nominal level.
Posted Nov 07, 2025 - 15:19 UTC

Monitoring

The mitigation is being deployed. We are monitoring the load to ensure it will come back to its nominal level.
Posted Nov 07, 2025 - 14:41 UTC

Identified

The issue has been identified and we working to mitigate it as it slows down the API response time.
Posted Nov 07, 2025 - 14:19 UTC

Investigating

We are currently observing a high load on our database, we are investigating the cause.
Posted Nov 07, 2025 - 13:52 UTC
This incident affected: Pix4D Licensing system, PIX4Dcloud, and PIX4Dengine Cloud API.